The customer support system issue has been fully resolved. All chat and voice support channels have been restored and are operating normally. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
No components marked as affected
Resolved
The customer support system issue has been fully resolved. All chat and voice support channels have been restored and are operating normally. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Resolved
The customer support system issue has been fully resolved. All chat and voice support channels have been restored and are operating normally. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Monitoring
We have implemented a fix for the customer support system issue and are monitoring the situation closely. Chat and voice support availability should be returning to normal. If you continue to experience issues reaching support, please email us at support@navan.com. We apologize for the disruption.
Identified
Navan is currently experiencing a temporary disruption with our customer support systems. As a result, chat and voice support may be unavailable or experiencing significant delays. Our engineering team is actively working to restore full service. In the meantime, you can reach us via email at support@navan.com. We apologize for this inconvenience and appreciate your patience.