The flight inventory issue has been fully resolved. All flight search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Resolved
The flight inventory issue has been fully resolved. All flight search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Monitoring
We have implemented a fix for the flight inventory issue and some of the impacted inventory has recovered.
We continue to work on the remaining inventory and are monitoring the situation closely. Flight availability should be now improved. We apologize for the disruption.
Identified
Navan is currently experiencing a temporary disruption in service with one of our flight providers. As a result, some flight inventory is unavailable. Our engineering team is actively working to restore full service. We apologize for this inconvenience and appreciate your patience.