Resolved
The site has fully recovered. If you encounter a problem, please reach out to our support.
Monitoring
A fix has been applied and the site is recovering. We continue to monitor
Investigating
Navan is aware of a site performance degradation. Our engineering team is troubleshooting the incident. We are sorry for the interruption and will continue to update as we make progress