Increased Booking Failures
Resolved·Degraded performance

This incident has been fully resolved. All services are operating normally, and you should no longer be experiencing issues with flight and hotel booking. We deeply apologize for the impact this had on you and your work. Our team will be conducting a thorough post-incident review to prevent this from happening again.

Mon, Oct 6, 2025, 05:59 PM
(3 months ago)
·
Affected components
Travel
Expense
Updates

Resolved

This incident has been fully resolved. All services are operating normally, and you should no longer be experiencing issues with flight and hotel booking. We deeply apologize for the impact this had on you and your work. Our team will be conducting a thorough post-incident review to prevent this from happening again.

Mon, Oct 6, 2025, 05:59 PM

Monitoring

We have deployed a fix and are seeing performance for [service/feature affected] return to normal. We are now closely monitoring the system to ensure full stability is restored. Thank you for your patience as we worked through this.

Mon, Oct 6, 2025, 02:55 PM(3 hours earlier)

Investigating

Issues with our payment backend are causing intermiitent booking failures.

Mon, Oct 6, 2025, 02:49 PM