Flight and hotel provider disruption
Resolved·Degraded performance

The flight and hotel inventory issue has been fully resolved. All flight and hotel search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.

Fri, Dec 5, 2025, 02:15 PM
(2 months ago)
·
Affected components
Travel
Updates

Resolved

The flight and hotel inventory issue has been fully resolved. All flight and hotel search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.

Fri, Dec 5, 2025, 02:15 PM

Monitoring

Our provider has implemented a fix for the flight and hotel inventory issue and we are monitoring the situation closely. Flight and hotel inventory availability should be returning to normal. If you continue to experience issues, please contact support. We apologize for the disruption.

Mon, Dec 1, 2025, 06:15 PM(3 days earlier)

Identified

Navan is currently experiencing a temporary disruption in service with one of our flight and hotel providers. Our redundant provider has taken over, however as a result, some flight and hotel inventory may be unavailable. Our engineering team is actively working to restore full service. We apologize for this inconvenience and appreciate your patience.

Mon, Dec 1, 2025, 05:07 PM(1 hour earlier)