The flight inventory issue has been fully resolved. All flight search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Resolved
The flight inventory issue has been fully resolved. All flight search and booking functionality has been restored. Thank you for your patience during this incident. If you continue to experience any issues, please contact our support team.
Monitoring
The flight inventory issue has recovered and we continue to monitor the situation closely. Flight availability should be have returned to normal. If you continue to experience issues, please contact support. We apologize for the disruption.
Investigating
Navan is investigating reports of issues with flight inventory availability. Some users may experience difficulty viewing or booking flights. Our team is actively looking into the issue and we will provide updates as we learn more. We apologize for any inconvenience.