·
We have performed all root cause remediation actions.
Resolved
Monitoring
The issue has been resolved, we are working on root cause.
Investigating
Some users are experiencing an error when accessing Navan, due to a particular service failure.